This flash component requires Internet Explorer (it will not work with FireFox, Chrome, Safari, etc.)